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create a new annotation document

1. In the File menu, select New...

2. In the File browser, navigate to the folder 
containing the media file(s) and select one or more 
media files. Click the “copy to right” button (“>>“)
or double-click the media file. The right panel lists 
the selected file(s) for the new document.
The first file in the list is the leading, the “master“ 
media. Up to 4 video files can be displayed 
simultaneously in the ELAN window.

3. A new document is created with the media 
player(s) and one tier named “default“.

4. In the File menu, select Save... or Save As... to 
save the new document as an ELAN Annotation 
File (.eaf).

Use the “File Format” box to only show files of a specific media 
file type, e.g. mpeg or wav.
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navigate the media and use the media controls

1. An extended, VCR style set of media controls 
is available for starting and pausing the media 
player and for stepping through the media.

The steps are:
1 pixel of the Timeline viewer, defaults to  •	
10 ms, depends on zoom level
1 frame, defaults to 40 ms (e.g. for audio)•	
1 second•	
1 scrollview (of the Timeline viewer) or “page“•	
to the end/to the begin of the media •	

For all these steps there is a variant to the left and 
to the right.

2. It is possible to jump to a certain point in 
the media by entering a time value in the Go 
To... dialog box. The time value can be entered 
in milliseconds, in seconds.milliseconds or in 
hours:minutes:seconds.milliseconds format.
The Go To... window is accessible via the Search 
menu or by double clicking the media time 
indicator just above the buttons.

3. It is possible to jump to a certain point in 
the media by clicking somewhere in the Density 
viewer; the width of this viewer represents the 
total duration of the media making it possible to 
roughly estimate where to jump to (e.g. at 3/4th 
of the media. Dragging the crosshair in this viewer 
is another way to quickly inspect the media.

4. In the Controls tab there are two sliders for 
changing the playback rate (slow motion / fast 
motion) of the media and the volume of the 
sound. 

5. When activating an annotation the media 
crosshair jumps to the begin time of that 
annotation. Stepping from one annotation to the 
next is another way of navigating the media.
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work with selections 

1. The most common way of creating a selection 
is by dragging with the mouse in any viewer area 
that has a time ruler. While dragging the crosshair 
moves with the mouse and the video is updated 
constantly.
The begin, end and duration of the current 
selection are displayed above the media and 
selection control buttons.

When referring to a “selection” in ELAN this is mostly about a selected time interval. Every audio and 
video file has a time axis and it is possible to highlight a segment of it by creating a selection. The 
selection can  be used for creating new annotations or changing existing ones.

2. When there is no selection it can be created 
by shift-clicking: a selection is created from the 
crosshair to where there has been clicked. 
When there is already a selection, shift-click can 
be used to add to or subtract from the selection.

3. Using selection mode in combination with the 
VCR style player buttons. In the example clicking 
the “1 second ahead “ button results in the selection 
being extended to the right with one second.

4. There are three Selection related buttons:
Play Selection, to only play the selected segment. •	
In combination with Loop Mode the selection is 
played multiple times.
Clear Selection, deselects the current selection •	
“Move crosshair to the left/right boundary of •	
the selection“

5. If a segment is selected and there is at least one 
tier, a new annotation can be created on that tier 
based on the selection. The annotation receives 
the begin and end time of the selection.
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create and modify annotations

1. A time-alignable annotation can be created on 
the junction of a selection and the active tier.
There are several ways to do so:

In the Annotation menu select New Annotation •	
Here
Right click on a tier and from the popup menu •	
select New Annotation Here
Double click in the area where a selection and a •	
time alignable tier intersect

How to create an annotation depends on the type of the tier the annotation has to be added to. On 
time-alignable tiers new annotations (usually) are created with based on a specific begin and end time. 
On non-alignable tiers annotations inherit time information from a parent annotation that they depend 
on.

2. A time-alignable annotation can be created 
on the active tier by using the keyboard shortcut 
Shift+Enter twice, at different points in the media 
time.  

Whenever a new annotation is created a text 
edit box will appear. Text can be entered and be 
committed by means of Ctrl+Enter.
The same text edit box appears when double 
clicking an existing annotation.

3. Some tier types support insertion of an 
annotation before or after an existing annotation.   
Activate an annotation on such tier and select:

in the Annotation menu New Annotation Before •	
or New Annotation After
the same items in the right mouse button popup •	
menu 

4. On a dependent tier a new annotation can be 
created by double clicking on the tier at a location 
where there is already an annotation on the parent 
tier. 

5. To delete an annotation activate it and select 
Delete Annotation in the right mouse button 
context menu or in the Annotation menu (Alt+D).
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create and modify annotations II

6. To modify the text of an annotation double click 
it and the annotation text editor appears. Changes 
should be committed by Control+Enter.

7. For longer annotation texts the annotation 
editor can be detached from the main window into 
a separate, resizable editor window.  Detaching 
and re-attaching can be achieved by Shift+Enter.

8. To remove the complete text of an annotation 
without opening the editor, select Remove 
Annotation Value in the right mouse button popup 
menu.

9. There are several ways to modify the time 
alignment of an existing annotation:

by using a selection:•	
activate an annotation, this sets the selection. 
change the selection by dragging the mouse, . 
shift clicking or by using selection mode in 
combination with the forward/backward 
buttons
press Control+Enter to update the annotation’s . 
alignment to match the selection

by dragging with the mouse:•	
activate an annotation. 
hold down the Alt key and click-drag the . 
annotation to the left or right
when Alt-clicking close to the left or right . 
boundary, only the left or right boundary is 
dragged

by shifting:•	
activate an annotation. 
from the Annotation menu select Shift > Active . 
Annotation
in the dialog window enter the number of . 
milliseconds to shift the annotation
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define and manage tiers

Tiers are containers for annotations, every annotation has to be added to a tier. By convention 
annotations on a single tier code for the same type of events (e.g. speech of participant A, left hand 
gestures of participant B etc.). Annotations on the same tier cannot overlap. 
Any number of tiers can be created and tiers can be grouped hierarchically (parent-child relations). 
Different predefined structural relations and constraints can be selected for depending tiers. The 
constraints are in turn defined in linguistic types.

1. To add a new tier select Add New Tier from the 
Tier menu. The window shows an overview of the 
current tiers and a tab pane for adding, changing, 
deleting and importing tier definitions.

The following attributes can be set for a tier:
Name - should be unique in the set of tiers•	
Participant - name or code for the participant or •	
subject this tier is referring to
Annotator - name or code of the creator of the •	
annotations on this tier
Parent: the parent tier of this tier or none•	
Linguistic Type - defines the type of this tier, the •	
constraints that apply to it and its annotations
Default Language - in practice a property for •	
input methods (virtual keyboard etc.)

2. Tiers can be managed in different ways, 
depending on the viewer. In the main editing area, 
the Timeline viewer, it is possible to:

activate a tier by double clicking its label•	
activate the next or previous tier by the •	
keyboard shortcuts Control+Arrow Down or 
Control+Arrow Up
sort the tiers hierarchically, or by their participant, •	
annotator or linguistic type attributes
change the order by dragging a tier’s label with •	
the mouse
hide and unhide tiers•	
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define linguistic types

A linguistic type consists of a number of constraints that can be applied to a tier and its annotations. 
Several predefined structural relations and constraints are available. A tier has to be associated with 
a linguistic type and is thus assigned to a certain type of linguistic data, for instance orthography, 
translation, part of speech, gesture phases etc.

1. To add a new linguistic type select Add New 
Linguistic Type from the Type menu. The window 
shows a table with the current types and a tab 
pane for adding, changing, deleting and importing 
type definitions.

The following attributes can be set for a linguistic 
type:

Name - should be unique in the set of types•	
Stereotype - None or one of four constraint types •	
(see below)
Controlled Vocabulary - none or one of the •	
available controlled vocabularies
ISO Data Category: the identifier of a data •	
category in ISOcat
Time-alignable - depends on the selected •	
Stereotype, can not be set by the user
References to Graphics Allowed - to be ignored, •	
leave this box unticked

2. The predefined Stereotypes are:

“Time Subdivision”

Time aligned subdivision of parent interval, no •	
gaps

“Symbolic Subdivision”

Ordered, symbolic subdivision of parent •	
interval

“Included In”

Time aligned subdivision of parent interval, •	
gaps are allowed

“Symbolic Association”

One-to-one association with the parent •	
annotation
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create dependent tiers (tier hierarchies)

Tiers can be set up as a child tier or dependent tier of another tier. Annotations on a dependent tier 
each are bound to an annotation on the parent tier, the time boundaries of the child annotation cannot 
exceed the boundaries of the parent annotation. In other words, the child annotations are always 
required to be inside the interval of the parent annotation.  

1. To create a dependent tier, first make sure a 
linguistic type with a proper Stereotype has been 
created:

“None“ is exclusively for tiers •	 without a parent
the other types are only for depending tiers•	

2. In the Add Tier window, first select the parent 
tier for the new tier and then select one of the 
available valid linguistic types.  The Stereotype 
of the linguistic type determines the kind of 
annotation that can be created on the tier.
As long no parent tier has been selected only the 
linguistic types with Stereotype “None” are listed.

A few additional constraints apply when setting 
up tiers: 

A tier of a “symbolic“ Stereotype (Symbolic •	
Subdivision, Symbolic Association) can not 
have a child tier of a time-alignable type (Time 
Subdivision, Included In).
Once a tier has been created and contains •	
annotations, it is not possible anymore to 
change its linguistic type to a type with another 
stereotype.

3. An overview of the tier dependencies in the 
annotation document can be created via the menu 
View > Tier Dependencies...

4. The tier dependencies can be used as a sorting 
criterium in the timeline view. The tier names 
are shown as a tree structure, similar to the tier 
dependencies window. 
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work with Controlled Vocabularies

A Controlled Vocabulary is a list of possible annotation values (or codes) that the annotator wants to 
use on one or more tiers. CV’s can be created and modified by the user and are part of the annotation 
document. CV’s can reduce typing errors and thus improve annotation consistency.

1. To define a new Controlled Vocabulary or 
change an existing one select Edit Controlled 
Vocabularies in the Edit menu.

2. The Edit Controlled Vocabulary window consists 
of two main parts. The upper part is for adding 
and changing the vocabularies. 

The lower part of the window is for adding and 
modifying the entries of the selected controlled 
vocabulary.
An entry consists of a value and an optional 
description. Besides that it is possible to link an 
entry to a data category defined in ISOcat.

3. When a tier has been associated with a controlled 
vocabulary (via its linguistic type), a drop down list 
appears the moment an annotation on that tier is 
created or edited allowing the user to select one 
of the values.
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create and use templates

A template is an annotation document without links to media files and without annotation but with the 
definitions tiers, linguistic types and controlled vocabularies. It can be created from any annotation 
document and can be used as the basis for new annotation documents.

1. To create a template chose File > Save as 
Template...
The extension for template files is .etf.

2. To create a new annotation document based 
on a template, follow the steps to create a new 
document.
In the File browser, click the Template button and 
navigate to a folder containing a template file. 
Select the .etf file and click the “copy to right” 
button (“>>“) or double-click the template file. 
The right panel now lists a template file and the 
selected media file(s) for the new document.

3. A new document is created with the media 
player(s) and all the tiers from the template.
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link annotations and tiers to a data category

It is possible to associate annotations and tiers with a data category in ISO’s Data Category Registry 
(ISOcat, www.isocat.org). The DCR defines widely accepted linguistic concepts. Each data category is 
assigned a unique identifier and it is this id that annotations and tiers can refer to.

1. Individual annotations can be associated with a 
data category. When there is an active annotation 
select Modify Annotation Data Category in the 
Annotation menu or in the context popup menu.

2. A window showing the local selection of data 
categories appears. The local selection acts as a 
cache for a part of the online registry.
A category can be picked from the list and applied 
to the annotation. The local cache can be modified 
via the Add Categories and the Remove Category 
buttons.

3. The window showing the contents of the remote 
registry has a similar layout. The data categories 
are grouped in profiles. After selecting a profile 
the categories of that profile are listed. The user 
can select multiple categories to add to the local 
cache. 

4. Linguistic types and entries in a controlled 
vocabulary can be associated with a data category 
much in the same way as individual annotations.
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customize ELAN’s behaviour via preferences

The behaviour of parts of the application can be customized to the user’s liking  and needs through 
preferences. The preferences are accessible via the Edit menu and are grouped in categories. Some of 
the main preference options are highlighted here.

1. In the Edit menu select Preferences > Edit 
Preferences... to open the preferences window 
or Preferences > Edit Shortcuts... to open the 
window that allows you to change the keyboard 
shortcuts.

2. The Edit Preferences window lists the available 
categories:

Editing•	
Media•	
Metadata•	
Platform/OS•	
Preferences•	
User Interface•	
Viewers•	

3. In the Editing pane one can specify that:
hitting the Enter key (without Ctrl) commits •	
changes in the annotation edit box
deselecting the edit box (e.g. by clicking outside •	
of it) commits the changes 

4. In the Media pane it is possible to change the 
behaviour of the frame forward and backward 
buttons to allways jump to the beginning of the 
next or previous frame.

5. In the Platform/OS pane platform and media 
framework specific options can be set.

6. The keyboard shortcuts for many actions can 
be changed or can be set. 
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use the Transcription mode

There are several different working modes, some of which are designed with a specific task in mind. 
The default mode is the Annotation Mode, a generic mode in which almost all functions are available. 
Most functions discussed in this document so far are shown in the Annotation Mode. Switching 
between modes can be done via the Options menu. The other modes are:

The Transcription Mode is optimized for typing 
text into existing annotations. Annotations are 
presented in a spreadsheet-like, tabular layout 
in which navigation (from one cell to another) is 
entirely keyboard driven. 
When a cell (i.e. annotation) is activated the 
corresponding segment of the media starts 
playing. 
The selection of the tiers that the user wants to 
be visible in the table is based on the type of the 
tiers; tiers of the same type are shown in the same 
column. E.g. the first column can contain all tiers 
of type “orthography“, the second column all tiers 
of type “translation” etc.

The Configure... button creates a window in which 
the tiers can be selected that the user wants to be 
visible in the table.
The selection of the tiers is based on the type of 
the tiers; tiers of the same type are shown in the 
same column. E.g. the first column can contain all 
tiers of type “orthography“, the second column all 
tiers of type “translation” etc.
This window also allows to specify the number of 
columns for the table. For the first column any tier 
type that is being used (by a tier) can be selected. 
For the next columns types can be selected that 
are fully time aligned with the first type, i.e. of 
type Symbolic Association. 
The Select Tiers... button makes it possible to 
create a more fine-grained tier selection per 
column.

After configuring the table there are several 
options for customizing the appearance of the 
cells and the overall behavior in this mode. Tiers 
can be made non-editable, navigation form cell-
to-cell can be performed across the columns or 
can stay within on column. 
The main keyboard shortcuts for this mode are 
TAB for playing the current segment again and 
ENTER for saving the changes to the current 
annotation, activating the next annotation and 
playing the corresponding interval.
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Segmentation Mode

The Segmentation Mode is designed for rapid 
and easy creation of empty annotations while the 
media is playing. Marking the begin and end time 
of annotations is done using the keyboard.
It is possible to change the boundaries of an 
annotation by dragging them with the mouse. 
Creating and changing the boundaries of an 
annotation in this mode does not require making 
a time selection first (like is the case in the 
Annotation Mode).

Synchronization Mode

The Synchronization Mode allows the user to 
synchronize media files (video, audio, timeseries) 
of which the recording didn’t start exactly at the 
same time. By setting an offset for some of the 
files in this mode, the media files will be played in 
sync in ELAN.
The media files will not be clipped, this 
synchronization has only consequences while 
working with them in ELAN. 

use Segmentation and Synchronization mode

The tier to which the new annotations are added 
is always displayed at the top, marked in red. 
Switching between tiers can quickly be done using 
the up and down arrow keys. The annotation the 
mouse is over can be dragged to a new position  
and be deleted using the Delete or the Backspace 
key.
The tiers in the list can be reduced to a minimum 
via the Show/Hide more... popup menu.

The Segmentation mode has an experimental 
“Step-and-Repeat” playback mode that can be 
configured to play segments of t milliseconds n 
times and then move the cursor t2 milliseconds 
forward and continue from there with the same 
procedure.


